SoundBlaster Audigy 2 ZS on Vista x64

Creative have been really sloppy at providing working and fully featured SoundBlaster drivers for Windows Vista, especially for older models of the card. When moving from XP to Vista I was dismayed to find the official drivers for my Audigy 2 ZS didn’t support CMSS2, Stereo Surround, Dolby Digital, or DTS, among other things. After much searching I found a solution that combines older functional drivers with the new Vista-compatible Creative Audio Console.

Note: I have only tried this on a fresh install of Vista Ultimate x64 with no existing SoundBlaster drivers installed. It may or may not work for you. Try it at your own risk.

  1. Download the required drivers. You’ll need both the 2.12.0002 and the older 2.12.0001.20 drivers.
  2. Install the newer drivers and Audio Console by running SBAXVSD_PCDRV_LB_2_12_0002.exe. Follow instructions and reboot.
  3. Extract the contents of SBAX_2_12_0001_20.zip into a temporary folder.
  4. Run the extracted Setup.exe and select “Driver Uninstallation” and “Delete all shared Creative audio driver files”. This uninstalls the drivers without removing the Creative Audio Console.

    Reboot.
  5. Run the same Setup.exe again, but this time select “Driver Installation” and “Overwrite existing shared Creative audio driver files”. This installs the older but functional drivers.

    Reboot.
  6. Driver installation is now finished. Open the Creative Audio Console and adjust your settings. CMSS2, Stereo Surround, Dolby Digital, and DTS are all available and working.

Creative recently released an Audigy series beta driver for Vista. I have not tried it as the above solution is working very well for me, but it may be worth checking out if you have tried this without success or you don’t like hacks like this.

Advertisements

Tags: , , ,

3 Responses to “SoundBlaster Audigy 2 ZS on Vista x64”

  1. Tyler Lovell Says:

    Your fix for Creative’s lack of support for CMSS2 and other audio settings, as listed HERE:

    https://alanbondo.wordpress.com/2008/06/21/soundblaster-audigy-2-zs-on-vista-x64/

    Worked perfectly for me. I use the exact same sound card and OS listed in that article, and the solution works like a dream. Thank you so much!

  2. jack manchester Says:

    thank you.

  3. WonderNull Says:

    Thanks so much, this is the holy grail for Vista64 (for me)

Comments are closed.


%d bloggers like this: